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ECE C61: Computer Architecture Design
Mentor Graphics Tutorial

Introduction
The purpose of this tutorial is to introduce you to the software you will be using to complete

the project of this course.  The computer-aided design (CAD) tools you will be using in this class
are from the Mentor Graphics Corporation (MGC) and run on the Solaris and HP workstations in
the Wilkinson Lab.

At the completion of this tutorial, you should be familiar with the design methodologies to be
used in this course.  You should also be somewhat familiar with the tools.  As you go through the
tutorial, be attentive; not everything can be explained in detail.  Trust your intuition. You will be
able to complete all assignments using the material presented here, but by experimenting with
other commands you may find other ways of doing things that are more efficient for you.

 If you go through the tutorial a step at a time, you should have no problems.  At least to start,
resist the urge to do things other ways.  Although it is possible to complete most tasks several
different ways, diverging from the way given in the tutorial may make it impossible for you to
continue.

Window Environment

You need to know how to move, resize, iconify, and de-iconify X windows before you attempt
this tutorial.  You may already be familiar with X-Windows from some of your previous classes
since it is common to many Unix platforms.  If you have any minor questions, feel free to ask a
TA or other students, but if you don’t have at least a working knowledge of these procedures, get
to Wilkinson soon to practice.

The Mentor Graphics Falcon Framework

The Mentor Graphics tools use Unix files and directories to represent schematics, simulations,
and layouts.  All of these objects are logically linked together.  Mentor provides a graphical tool
called Design Manager (dmgr) for viewing, moving, and copying design-related files while
maintaining design integrity.  Use of dmgr is not optional.  You must always use it when you
wish to move or copy designs.  The use of native Unix commands is not supported and if you
rename, remove, or copy MGC files using standard Unix commands, the probability is high that
you will corrupt your design beyond recovery.  Resist this urge.

MGC applications are large and can take a significant amount of time to perform certain tasks.
Sometimes it can be hard to tell if the application is busy or waiting.  You can determine if the
application is busy by iconifying and de-iconifying the graphic window.  If the application is not
busy, it will repaint the window immediately.

Occasionally, an MGC application will not respond to mouse clicks even though the tool is not
doing anything.  If this happens, raise the window to the top of the desktop using the window
manager.

Tutorial Format

This tutorial deals with the process of entering and simulating a design.



The tutorial is structured as a sequence of goals.  Each goal is achieved by executing a
combination of actions and goals.  Goals (and sub-goals) precede the actions needed to achieve
that goal.  The actions and sub-goals which fulfill a goal are indented under the goal.  Phrases set
in Helvetica refer to menus you must execute and other text in an MGC window.  Things set in
Courier indicate text that you enter or that an MGC application writes into a text window.
Notes, set in italics and justified right, are interspersed throughout the tutorial to further explain
goals and actions.

Comments/Tips

While you are working with this tutorial, make note of important steps and procedures, as you
will need to do these things repeatedly during the course of this class.  Highlighting, underlining,
paper-clipping are strongly suggested.

Mentor Graphics can be very picky at times, and the instructions given here may not always
explain why you are doing things.  Understandably, these two things go hand in hand to make
your life more difficult.  But, if you just pay attention to the tutorial, you should be able to
complete the assignments without much trouble.  All it takes is a little intuition.

Every time you open a new Mentor tool, such a simulator, viewpoint editor, schematic editor,
etc., Mentor creates a new terminal window along with the graphical tool window.  When you
close the tool, Mentor does not close the terminal window.  You should close this manually to
conserve system resources and to keep your desktop clutter-free.



Part 1: Design Entry

Login, start Design Manager, and copy the tutorial data

1. Log into one of the HP or Solaris workstations in Wilkinson.

We don’t cover how to do this here; if you don’t know how, ask the TA. It
is also possible to run the tools remotely from a PC using an X server

under windows, or Linux.  Special fonts are required.  See the NWU ECE
web pages for details and tutorials.

Set up your environment for ECEC61

2a. Source the mentor environment variables required to run the tool by typing

         source ~tdh/env/mgc.env at the unix prompt.

If you don’t do this successfully, all bets are off.  Be sure to comment out
left-over Mentor stuff from your various dotfiles, else this environment

script is designed to fail until you clean up.

2b.  Create (if necessary) a subdirectory for your mentor files, mkdir ~/MGC/ecec61

Start Design Manager

3. Type dmgr

Notice the transcript that is written to your xterm window.  This is a useful
place to look to see what the tool is doing as you perform commands.

Also, keep an eye out for errors in this window.

4. Find the window with a cyan (light blue) border

The default Design Manager window is composed of three subwindows,
two of which are inside the third.  Only one window is active at any given

time and the active window is outlined in cyan.  Inactive windows are
outlined in gray.

5. Find the file Navigator window

The window on the right is called the Navigator window and is used to
browse the file system.  The directory being displayed is shown in the

Navigator window’s title bar.  It should always contain ‘.../MGC/ right
after you start dmgr. Confusingly, the area containing icons on the far
right (known as the Palette) is labeled Navigator at the top.  This is the
Navigator Palette.  Try not to confuse this with the Navigator window,

which has a path name in its title bar.

6. Find the Tools window



The window on the left is the Tools window and can be used to invoke
Mentor tools by double clicking the left mouse button (LMB) on the

appropriate icon.

Examine pull down menus

7.Press and hold the LMB over MGC, near the top left corner of the Design
Manager window

8.While continuing to press the LMB, slide the mouse down until the entry Setup is
drawn with a box around it

9.While continuing to press the LMB, slide the mouse to the right and then down
until Session... is drawn with a box around it

10.Let go of the mouse button

You have just selected a cascade menu.  Throughout the tutorial, you will
see statements like Edit>Change>Name:  This means hold down the

LMB on the Edit menu, move the mouse down to the Change item, move
the mouse to the right until a submenu pops up, move the mouse to the

Name: item, and release the button.

11.Hit the ESC key

In all MGC applications, you can cancel a command that you have not yet
completely entered by hitting ESC.  Alternately, most dialog boxes and

prompt bars like the one shown have a Cancel button.

Examine pop up menus

12.Activate the Navigator window

Click the title bar of the window to activate it.

13.Press and hold the right mouse button (RMB)

This brings up a pop up menu.  The top line of the pop up menu identifies
its type.  Once you have popped up a menu, menu operation is identical to

that of a pull down menu.

14.Move the mouse outside all menus and release the button

If the mouse is not pointing within the menu when you release the button,
nothing happens.

Throughout the tutorial, you will see statements like
(Navigator)>Edit>Copy:  This means that you should activate the

Navigator window, press the RMB, go to the Edit item, move the mouse
right until a submenu appears, go to Copy:, and release the RMB.

Become familiar with the Navigator

The navigator is the normal method for starting applications.  Moreover,
many applications pop up a navigator window to help you select files to

open.

15. Activate the file Navigator window

16. Press the button with four arrows on it

17. Enter /homes/elib/MGC/TA/ecec61 into the white box and press the OK
button



The four arrow button allows you to move directly to a directory by typing
a path instead of having to use the up and down arrows.

18. Press the LMB on the xor

This is called selecting.  From here on out, we will use the phrase
‘Select...’ to indicate you should press the LMB on the appropriate object.

This applies to all MGC tools, windows, and dialog boxes.

The LMB is by far the most used mouse button, so now on, if no button is
specified, use the LMB.

19. Press the down arrow icon in the Navigator window.  Now, press the up arrow icon.

This is equivalent to cd’ing into the selected directory.

20. Select the xor

21. Double click on the xor folder

Double clicking on a folder is equivalent to pressing the down arrow icon.

22. Press the up arrow

This is equivalent to ‘cd ..’ and is the opposite of the down arrow.

23.Press the down arrow

At the bottom of the Navigator window, you see four buttons with arrows.
The down button, when pushed, goes into the selected subdirectory.  The
up button goes to the parent directory.  The button with four arrows on it
can be used to go to any directory you type in.  The right arrow icon can

be used to examine all files referred to by the selected object (don’t worry
about this for now).

We’ll provide a few more examples of how to use the Navigator.  After
that, we’ll simply sat ‘Select... using the Navigator’ and leave the details

up to you.

24.Close the Tools window

Use your experience with other window managers to figure out how.

Copy the xor example

Navigate to the source directory using a new navigator window

25. (Session)>Open Navigator

Remember, this means press the RMB in the session window, move the
mouse until the Open Navigator entry is highlighted and then release the

button.  Note that we did not go down into the submenu of Open
Navigator.

Note that what you get on the RMB pop-up menus is dependent on where
the pointer is.  To get the session pop-up, the pointer must over the gray

background and not over an active window.

The main window/context of dmgr is called ‘Session’, not Design
Manager.  Mentor is a little inconsistent here.



26. Press the four-arrow button

Also called the directory button.

27. Enter /homes/elib/MGC/TA/ecec61

28. Select the xor folder

29. (Navigator)>Edit>Copy

Fill in the prompt bar that has appeared in the lower left corner

30. Put the mouse over the white area following the word Destination

Fields are selected by moving the cursor over them and clicking the LMB.
When a field is active, it is outlined in red.

31. Enter $HOME/MGC/ecec61

32. Press the Options... button

A dialog box is popped up.  If our window is too small, you won’t be able
to see the whole thing.  You can either make the main X window bigger or
you can use the Page Up and Page Down keys.  There are no ‘page left’

and ‘page right’ functions, but moving the mouse will cause the box to
scroll.

33. Select Entire Object under Copy Mode (this should be the default).  Use the
defaults for the other modes too.

This is a change from the old tutorial, which used only Current Version.
Some interaction with the C.4 tools on B.1 data seems to cause problems

otherwise.  --Todd Haverkos Jan 2000.

34. Press OK in the Copy Object Options dialog box

35. Press Return key for prompt bar

You can usually hit Return instead of pressing OK.  We call this action
‘okaying the dialog box’ or ‘executing the dialog box’.

This copy will take some time to complete.  When it is done, it will display
an informational comment at the bottom of the dmgr graphic window to

that effect.

36. Activate the $HOME/MGC/ecec61 Navigator window

If you lost it, you can always navigate back to your directory using the 4-
way arrow button.

37. (Navigator)>Update Window

38. Close the /homes/elib/MGC/TA/ecec61 Navigator window

         Open the XOR schematic

39. Select the xorcomponent

40. (Navigator)>Open>1 design_arch

You will get a warning stating that the sheet has not been checked
successfully.



Anytime you open an application from dmgr, two windows will appear: a
text window and a graphic window.  Most commands you enter in the

graphic window show as text in the text window.  Error and status
messages go to the text window and the most recent message is also

displayed at the bottom of the graphic window.  The text window may be
closed, but it is recommended that you keep it to view any error messages.

It can also be iconified to get it out of the way.

dmgr does not have a separate text window... it uses the window you
started it from.

41. Press the maximize button for the schematic window

.

This will eventually be the top level design, once all the missing pieces are
filled in.  All the data you copied is partially complete and will not start
out looking exactly like the figures.  You will complete the given data so

that it matches this writeup.

42. Type Shift-F8

This is a View All command.  At the bottom of the screen, you’ll notice a
map of the function keys.  These provide shortcuts to many commands.

43. Press the RMB in one of the scroll bars of the schematic window and select View
Area:

44. Drag the LMB in the schematic window to create a rectangle

Your viewpoint changes to the specified rectangle

45. Zoom out to view the entire schematic

46. iconify the XOR schematic

47. View All

48. (Schematic)>Undo>Undo

In general, if you make a mistake, you can undo it.  Undo is usually three
deep, but some commands destroy the undo stack.  If you make a mistake

from here on out, we will assume you will undo it and try again.

49. (Schematic)>Undo>Redo

Redo undoes an undo.

50. Find the schematic palette in the center on the right



51. Make sure you’re in the Add/Route menu at the top

There are four menu titles at the top in red.  The active one is highlighted.

Add the nand gatesoutput port

52. Press the right arrow on the scroll bar at the bottom of the schematic window

53. Libraries>MGC Digital Libraries>Display Libraries Palette

54. Select gen_lib.

55. Select Libraries from the menu bar, not the schematic palette..

56. Point the mouse in the gen_lib palette and use the Page Up and Page Down keys
until portout shows in the palette

You can also hit (Palette)>Show Scroll Bars and drag the bar with the LMB if you
think it would be faster.

57. Click on portout and move the mouse back into the schematic window

58. Place the shadow port so that the center of the ‘+’ is on the end of the output net

59. (Palette)>Back

Selecting entries moves you into libraries.  Back moves you out.

60. (Palette)>Display Schematic Palette

You can use this command so you don’t have to use Back through many
layers of library menus.

61. Point in the schematic window and press the F2 key

Look at the function key map.  F2 executes the
command Unselect All in the active window.

Objects in white dashed lines are selected.  Many commands like Copy
and Move act on the current selection.

            In the upper left hand corner under the main menu bar is the label Sel:, a
number, and possibly a +.  The number is the number of currently selected
objects.  The + indicates that selecting another object will add to the set of

selected objects.  If there is no +, selecting an object will unselect everything and
then select the new object.

62. Point at the NET text and press the F1 key

63. If the text did not select but something else did, press F2 and try again until the text
alone is selected

In general, most selection commands (for example, just selecting with the
LMB in the schematic window) will not select property text such as a net
name or transistor lengths and widths.  F1 is an exception; it executes a

Select Anything command.

64. (Schematic)>Change Values:

Notice that when you hit the RMB, a menu titled Property/Text appeared.
The schematic window opens menus depending on what you have selected.

65. Point at the word NET in the value field

66. Click, backspace three times, type C, and hit return



67. Press F2

68. Hold the RMB

Notice an Add menu appears when nothing is selected.

68. View All

              69. Libraries>MGC Digital Libraries>Display Libraries Palette
61. Select gen_lib.

Select Libraries from the menu bar, not the schematic palette..

62. Point the mouse in the gen_lib palette and use the Page Up and Page Down keys
until nand2 shows in the palette

You can also hit (Palette)>Show Scroll Bars and drag the bar with the
LMB if you think it would be faster.

63. Click on nand2 and move the mouse back into the schematic window

64. Place it so its two inputs touch the two wires coming straight out of the A and B
ports.

65. Press the Copy button

66. Place the second gate such that the upper pin is attached to the upper wire in the
sheet

67. When the Select Area prompt box appears, select the NAND that you just placed

Notice that Repeat is true in the Copy prompt box.  you will continue to
copy whatever you select until you hit ESC.

68. Place the third NAND such that the lower pin is attached to the lower wire

69. Place the final NAND such that the output is attached to the output wire

Remember to hit ESC now.

you can use Undo from within the Copy command... it ‘undoes’ the last
placement but keeps you in Copy.

70. Press Connect All if necessary

Wire up the gates

71. View All

72. If the grid does not show, make your X window bigger and View All again

73. Push the Add Wire button

74. Point the mouse at the output pin of the leftmost NAND gate and click the LMB

75. Move the mouse one grid unit to the right and click the LMB

76. Move the mouse straight up until it is one unit to the left of the lower pin on the
topmost NAND gate and click the LMB

77. Move the mouse to the pin and double click the LMB

78. Move to the top pin of the lowest NAND gate and click the LMB

79. Move to the left one grid unit and click the LMB



80. Move straight up until the mouse points at the place where the output of the
previous net turns upward and double click the LMB

81. Wire up the final two nets in a similar manner

It is not considered good style to use diagonal nets.

82. Hit ESC to end the Add Wire command

Check the schematic
83. Check>Sheet

There should be no errors or warnings.

All schematic sheets should be checked before they are saved.  If you save
a schematic without checking it, you will get an error if you try to read it

using other tools.

84. Close the Report window

85. Check>Schematic

There should be no errors but interface warnings.

A schematic can have multiple sheets.  When you check a schematic, all
sheets are checked and then inter-sheet connectivity is checked.

86. Close the Report window

87. File>Save Sheet

88. Close the schematic

Create the symbol

Open the symbol

89. Miscellaneous>Generate symbol

90. Choose Yes for “Replace existing” option and press OK

Symbol sheet will be opened by input pis A and B and outpin C

Check the symbol

91. Check>With Defaults

There should be no warnings or errors.

92. Close the Report window

93. File>Save Symbol

Copying an existing symbol in this manner is one of the easiest methods of
creating new symbols.  Its very nice for things that are hard to draw

correctly, i.e. symbols with curves in them.

94.close the symbol sheet

95. go back to xor schematic sheet

96.Check>schematic



There should be no error or warnings.

97.close the schematic sheet

98.close the design_arch

Simulate the XOR gate

Now that we have a schematic and symbol, we want to simulate it to make
sure it is right before creating other circuits that use it.  In general, you
always want to test small blocks of your design in isolation.  If you wait

until you have a large design, it will be difficult to debug.

We will do both digital and analog simulation of the XOR gate.

Create a design viewpoint for digital simulation

119. Bring the Design Manager window to the top of the desktop

120. Select the xor component in .../MGC/ecec61/xor

121. (Navigator)>Open>4 DVE

dve is the Design Viewpoint Editor.  Because we do both digital and
analog simulation on the same design, we have to set up viewpoints from

which each simulator can determine how to get only that information
which it needs.

122. Setup>(Quick)Sim, Fault, Path, and Grade

This sets up the generic information needed by QuickSimII, the digital
simulator.

123. Edit>Add>Primitive...

124. Enter model for Name and analog for Value

125. Execute the dialog box

You’re not expected to understand this.It has to do with Viewpoints, or
different methods by which different Mentor tools can view a given design
object.  A digital simulator should have one opinion of a nand gate, while
an analog simulator needs different information.Rather than drawing two

different schematics, we use a single design object with multiple
viewpoints.

126. File>Save Design Viewpoint>Save As...

127. Enter digital in the dialog box and okay it

You should get a message saying Removed empty viewpoint: default.
dve creates a viewpoint called default if a name isn’t specified when it is

first created.  When you saved the viewpoint as ‘digital’, the empty default
was deleted.

128. (DVE Session)>Close Design Viewpoint...

This closes the digital viewpoint of the nand gate we just created for
Quicksim.

1



129. Close dve

This step is optional, but recommended.  Keeping all MGC applications
open at all times may cause problems or may slow down your work.  You

may not want to keep too many unneeded applications (like dve) open
when not in use.  It bogs down your machine, and more importantly uses

valuable licenses for various tools.

Digitally simulate the XOR gate

130. Select the digital viewpoint object in the Navigator window

131. (Navigator)>Open>B QuickSimII

132. File>Check Design...

133. Select Simulation Checks? Yes and Expand Messages? Yes and execute the
dialog box.

There should not be any messages.

It is a good idea to check your design every time you start quicksim.

134. Setup>Kernel

135. Press Visible

136. Select the Change button next to the phrase Timing Mode

137. Select Full Delays Min

138. Press Hidden and execute the dialog box

This sets the timing mode and should be done each time you start the
simulator.

139. (Quicksim)>Open>Sheet

140. Select the port objects for A, B, and C

This actually selects the nets that the ports are attached to.

141. (Quicksim)>Add>Traces

142. If necessary, expand the Traces window so that you can see all three of the values

143. (Quicksim)>Force>Clock...

144. Enter the following information: Signal name A and okay the
dialog box

Period: 100n

Absolute check
Force type: fixed

A isn’t really a clock.  In this context, ‘clock’ means a periodic waveform.

145. Bring up the stimulus menu from the palette on the right

146. Press the Add Clock button to create a force for B with the same information as
above except as shown: Period: 50n

147. With the mouse in any of the quicksim windows, type init 0r and hit return

You could have executed this command from the menus, but you can also
type commands in directly.  All menu commands have a form that can be

typed in .  Which form you use is entirely up to you.



148. With the mouse in any of the quicksim windows, type run 10 and hit return

149. (Quicksim)>Run>Reset...

150. Choose State, unchoose Save ‘results’ Waveform DB, and execute the dialog box

This resets the simulation time to zero.  If you don’t execute this, future
run commands continue from the current state.  Force commands are also

relative to the current time, so you will usually want to reset the
simulation before modifying a force.

151. With the mouse in any of the quicksim windows, type init 0r and hit return

This initializes the simulator for a run.  You need to execute the init
command every time you are going to use the run command and the

current time is 0, i.e. on the first run command or when you have just
executed Run>Reset>State.

152. Type run 100 and hit return

The number given to run is always in nanoseconds... don’t type 100n.

The simulation should be correct for a NAND gate.

153. Close quicksim

154. Select the Without saving button from the exit dialog box

While it is often useful to keep applications like Design Architect and
Design Manager open at all times, it is not as useful to keep the

simulators open since you can’t switch the current design.

Note that the text window that dmgr created for quicksim did not go
away.  All applications started by dmgr run this way.  This allows you to

keep windows containing errors up after an application has
terminated155. Close the quicksim text window


